Customer Websites Degraded Performance
Incident Report for Prospect CRM's
Postmortem

At approximately 15:30pm on November 21st a subset of Prospect hosted sites experienced some degraded performance including timing out and slowness. The product team were able to apply to identify the root cause of the disruption and a fix was being worked on by 15:am, and deployed at 15:57pm that would resolve the issue.

The root cause was identified as being an issue with the deployment process for updates made by the Product and Infrastructure teams. The necessary fixes were planned into upcoming work sprints to ensure that the long-term solutions put in place resolved the issue causing the outage.

These fixes have been deployed and should prevent any reoccurrence of this issue.

Posted Jan 15, 2025 - 16:14 GMT

Resolved
This incident has been resolved.
Posted Nov 21, 2024 - 16:37 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 21, 2024 - 15:57 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 21, 2024 - 15:53 GMT
Investigating
We are currently investigating an issue related to a subset customer websites responding slower than expected or timing out. We will provide further updates as information becomes available.
Posted Nov 21, 2024 - 15:39 GMT
This incident affected: Our Website and Individual Prospect Apps (Prospect CMS Editor App, Hosted Customer Websites, Portals and eCommerce sites).