Prospect CRM Degraded Performance
Incident Report for Prospect CRM's
Resolved
The performance problems reported yesterday have been resolved.
Posted May 24, 2023 - 09:30 BST
Monitoring
Prospect CRM performance has returned to normal. We are monitoring the situation and are investigating the root cause of the issue.
Posted May 23, 2023 - 17:12 BST
Investigating
We are currently investigating reports of degraded performance in the Prospect CRM App. We are currently investigating the issue and working to resolve it as quickly as possible. We will provide updates as we have more information.
Posted May 23, 2023 - 16:53 BST
This incident affected: Individual Prospect Apps (Prospect CRM App).