Save To CRM Login Issues
Incident Report for Prospect CRM's
Resolved
This incident has been resolved.
Posted May 20, 2021 - 17:19 BST
Monitoring
Some users are experiencing issues using Save to CRM in both Desktop and Web Outlook. Although we have identified and fixed the root cause users may need to clear their browser cache in order to resolve issues on their device. Please follow this guide for instructions on how to do this http://docs.prospect365.com/en/articles/4304884-resolving-browser-related-issues-clearing-browser-caches

Any further problems should be reported to us by emailing help@prospectsoft.com
Posted Apr 09, 2021 - 12:00 BST