Degraded performance of Prospect CRM
Incident Report for Prospect CRM's
Postmortem

At approximately 9:38am the slow request limit was reached which was detected by our Auto-heal rules. This queued the instance logging the slow requests to recycle.

There was a brief degradation of performance while the instance was handling the slow requests and then while it was recycled, once this was fully complete normal performance was resumed at around 9:47am.

Auto-heal rules are a normal part of system operations and do not typically impact on performance in this way. We are therefore carrying out further investigation into improving the speed of these recycles to mitigate further impact of instance recycling.

Posted Jul 02, 2024 - 16:22 BST

Resolved
This incident has been resolved.
Posted Jul 02, 2024 - 11:13 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2024 - 10:58 BST
Investigating
Some customers have reported slower than expected performance of Prospect CRM and associated services. We are currently investigating and will provide further updates as information becomes available.
Posted Jul 02, 2024 - 10:51 BST
This incident affected: Individual Prospect Apps (Prospect CRM App) and APIs, Login, and Core Platform.