Ideas portal unavailable
Incident Report for Prospect
Resolved
Maintenance has been completed.
Posted 14 days ago. Aug 09, 2019 - 13:04 BST
Monitoring
The ideas portal is currently unavailable due to emergency maintenance being performed by the service vendor. The ideas portal is expected to be available again by 6pm BST.
Posted 14 days ago. Aug 09, 2019 - 12:22 BST
This incident affected: Our Website.