Customer sites running slow or timing out

Incident Report for Prospect CRM's

Resolved

This incident has been resolved.
Posted May 30, 2024 - 11:22 BST

Monitoring

Website performance should be restored and we are monitoring the results.
Posted May 30, 2024 - 10:54 BST

Investigating

We are currently investigating an issue related to customer websites responding slower than expected or timing out. We will provide further updates as information becomes available.
Posted May 30, 2024 - 10:32 BST
This incident affected: Our Website and Individual Prospect Apps (Prospect CMS Editor App, Hosted Customer Websites, Portals and eCommerce sites).