Degraded performance of Prospect CRM

Incident Report for Prospect CRM's

Resolved

Microsoft have resolved the issue regarding FrontDoor resource. You can read about the incident on their status page at https://azure.status.microsoft/en-gb/status/history/
Posted Oct 10, 2025 - 08:20 BST

Identified

https://azure.status.microsoft/en-gb/status#

Microsoft have identified a global issue with their Front Door service. Please check the link above for updates directly from the Microsoft team.
Posted Oct 09, 2025 - 11:45 BST

Investigating

We are currently investigating and will provide further updates as information becomes available.
Posted Oct 09, 2025 - 09:26 BST
This incident affected: Individual Prospect Apps (Prospect CRM App, Prospect CMS Editor App, Hosted Customer Websites, Portals and eCommerce sites) and Our Website, APIs, Login, and Core Platform.