Degraded performance of Prospect CRM

Incident Report for Prospect CRM's

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 09:07 BST

Monitoring

We have identified the issue that led to degraded access to the CRM and have restored service. We will continue to monitor it's status.
Posted Apr 14, 2025 - 07:11 BST

Update

We are continuing to investigate this issue.
Posted Apr 14, 2025 - 06:13 BST

Investigating

Customers based in Australia have reported slower than expected performance of Prospect CRM and associated services We are currently investigating and will provide further updates as information becomes available.
Posted Apr 14, 2025 - 06:13 BST
This incident affected: Individual Prospect Apps (Prospect CRM App).