Investigating issue with CRM slowness in APAC

Incident Report for Prospect CRM's

Resolved

We have identified the issue and applied a fix. We will continue to monitor our services to ensure stability.
Posted Jul 10, 2025 - 01:45 BST

Investigating

We are currently investigating an issue that is causing the CRM to run slowly in the APAC region. We will provide updates as we continue to investigate.
Posted Jul 10, 2025 - 00:59 BST
This incident affected: Individual Prospect Apps (Prospect CRM App) and APIs, Login, and Core Platform.