Processing delays with accounts/ERP sync and order confirmations
Incident Report for Prospect CRM's
Postmortem

At approximately 9am on 9/8, an update supporting the latest CRM release was deployed which included an additional flag in the order confirmation messages for cloud ERP integration. The service bus filter was updated to take this new flag into account after the deployment, however this deployment was then rolled back due to an unrelated issue.

The change to the filter and rollback meant that the flag was no longer included in the order confirmation requests, causing them to not be correctly processed. We were able to identify and resolve this issue and ensure that the changes were redeployed. Any orders that were confirmed while this was live would have been stuck in the "Waiting to be confirmed" status and would need to be retriggered manually, either by toggling it on and then off hold, or alternatively cancelling, restoring and reconfirming the quote.

Posted Aug 13, 2024 - 15:25 BST

Resolved
This incident has now been resolved. Any orders that are still pending will need to be retried, you can do this by cancelling, restoring and then confirming the order.
Posted Aug 09, 2024 - 11:48 BST
Monitoring
A fix has been put live and we are monitoring the results. Any affected quotes will need to be cancelled, restored and then retried. If you are unsure how to do this please reach out to the support team!
Posted Aug 09, 2024 - 11:04 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 09, 2024 - 10:59 BST
Investigating
Some customers my be experiencing delays with data synchronising between their accounts/ERP system and Prospect, including order confirmations. We are currently investigating the issue and will provide further updates as information becomes available.
Posted Aug 09, 2024 - 10:15 BST
This incident affected: Automation and Integration (Cloud Inventory Management Integration Services).