CRM Email Spam Issues
Incident Report for Prospect CRM's
Resolved
Customers are now able upgrade their email sending account to resolve email deliverability issues. If you have not done so already please do this by going to your domain system settings page in the CRM. (https://crm.prospect365.com/admin/domains)

If you have any questions or problems please contact help@prospectsoft.com
Posted Apr 27, 2023 - 09:13 BST
Update
We have coded changes to our systems to improve email deliverability. These improvements will be available to customers in version 102. When you are updated you will be notified along with any instructions to take full advantage of this update.
Posted Mar 16, 2023 - 10:58 GMT
Update
While we wait for individual mail providers to unblock the rest of these emails we are taking further proactive steps to speed up this process.
Posted Mar 03, 2023 - 16:59 GMT
Update
All third party spam filters are now updated. Some individual mail providers may still be blocking emails and will take some time to filter through. Click-tracking remains disabled until we are confident most providers are not blocking emails.
Posted Feb 27, 2023 - 13:15 GMT
Update
We have successfully resolved the root issue and are now actively working to clear up listings on third party spam filters. Some residual impact will continue for 24-48 hours while different providers catch up and propagate the changes.
We will then look at reactivating click-tracking for CRM emails.
Posted Feb 23, 2023 - 15:43 GMT
Monitoring
All identified spam protection providers have been notified, this may take some time to filter through to individual email spam filters.
Posted Feb 22, 2023 - 15:28 GMT
Identified
We have reports of emails coming from the CRM being blocked by recipients spam filters. This is a result of the recent email sending problems and we are working to get this resolved with the spam protection providers as soon as we can.
Posted Feb 22, 2023 - 09:21 GMT
This incident affected: Individual Prospect Apps (Prospect CRM App).