Degraded performance of Prospect CRM
Incident Report for Prospect CRM's
Resolved
This incident has been resolved.
Posted Jun 15, 2020 - 14:13 BST
Update
We have mitigated the issue however we are still investigating the root cause.
Posted Jun 15, 2020 - 10:39 BST
Investigating
Some customers have reported slower than expected performance of Prospect CRM and associated services. We are currently investigating and will provide further updates as information becomes available.
Posted Jun 15, 2020 - 10:11 BST
This incident affected: Individual Prospect Apps (Prospect CRM App).