Customer sites running slow or timing out
Incident Report for Prospect CRM's
Resolved
Microsoft have resolved the issue within Azure resuming full service.
Posted Oct 23, 2019 - 02:39 BST
Identified
A subset of customer sites are responding slower than expected or timing out. Microsoft have identified an issue related to storage accounts within Azure and actively investigating the issue.

We will provide further updates as information becomes available.
Posted Oct 22, 2019 - 23:31 BST
This incident affected: Our Website and Individual Prospect Apps (Prospect CMS Editor App, Hosted Customer Websites, Portals and eCommerce sites).