Prospect 365 CRM Performance Issues
Incident Report for Prospect CRM's
Resolved
This incident has been resolved.
Posted Nov 14, 2021 - 08:41 GMT
Monitoring
The issue has been mitigated and we are closely monitoring the situation.
Posted Nov 03, 2021 - 09:19 GMT
Investigating
We are currently investigating reports of CRM slowness, please bear with us while we find the cause of the issue.
Posted Nov 02, 2021 - 15:36 GMT
This incident affected: Individual Prospect Apps (Prospect CRM App).