Stripe CMS payment plug-in not functioning
Incident Report for Prospect CRM's
Postmortem

On the 18th July 2024 a change to our CMS was deployed that stopped the Stripe CMS payment plug-in from loading correctly on CMS websites.

This was raised as an urgent issue with the Product team, and a hotfix was coded ready for deployment, however due to an outstanding live CMS deployment issue, this was unable to be deployed until Monday 22nd July 2024.

Affected customers were contacted to advise the issue had been identified, and workarounds were put in place to temporarily disable the affected payment pages, with a message to call or email in to make a payment over the telephone.

The fixed code was deployed in the afternoon of 22nd July 2024 and affected customers were notified so they could remove any temporary messages placed on their websites.

The root cause of this incident was due to an update to the encryption library that we were using to resolve a security issue. The fix for the encryption issue was included in a CMS release on the 17th May 2024, however this code was not merged back into into the main branch, so an updated deployment on the 18th did not contain the fixed code. The code was merged and ready to deploy on the 22nd as soon as the outstanding CMS gateway deployment issues were made live.

Posted Jul 24, 2024 - 14:42 BST

Resolved
The CMS gateway deployment has resolved the outstanding issues with the Stripe payment plug-in.
Posted Jul 22, 2024 - 17:13 BST
Monitoring
An update has now been deployed which appears to have resolved the issues with the Stripe plug-in not loading correctly. We will continue to monitor the situation.
Posted Jul 22, 2024 - 16:58 BST
Update
We are continuing to work on a resolution to this issue. We will update the status of the incident when an update has been deployed to resolve these outstanding issues.
Posted Jul 22, 2024 - 15:26 BST
Identified
An issue has been discovered with the Stripe Payments CMS plug-in, which stops the plug-in from functioning correctly and displays an error: "An unexpected error occurred". This issue will stop customers from being able to check out online, unless they also have the option to pay 'On Account'.

The CRM Stripe integration page is unaffected by this issue.

If you are affected by this issue, please get in contact with the Service Desk by logging a ticket online at https://services.prospectsoft.com/log-ticket or emailing help@prospectsoft.com so we can help you deploy a temporary message on your website, and assist taking card payments over the telephone.
Posted Jul 22, 2024 - 11:21 BST
This incident affected: Individual Prospect Apps (Hosted Customer Websites, Portals and eCommerce sites).