Degraded performance of Prospect CRM and Customer Websites

Incident Report for Prospect CRM's

Resolved

Microsoft have resolved the incident regarding their DNS service. You can find their post-mortem on the issue at https://azure.status.microsoft/en-gb/status/history/
Posted Oct 30, 2025 - 08:16 GMT

Monitoring

Microsoft have carried out restorative actions to bring back the affected services. The CRM and customer websites should be operational and we will continue to monitor our services to ensure stability.
Posted Oct 29, 2025 - 22:07 GMT

Update

Microsoft continue investigations and have found the underlying cause of the outage within their infrastructure. Microsoft are now applying restoration actions.

Latest update from Microsoft: https://azure.status.microsoft/en-gb/status
Posted Oct 29, 2025 - 18:46 GMT

Identified

https://azure.status.microsoft/en-gb/status#

Microsoft have identified a global issue with their DNS service which is currently affecting the CRM as well as customer websites. Please check the link above for updates directly from the Microsoft team.

We will continue to keep an eye on this issue.
Posted Oct 29, 2025 - 16:57 GMT
This incident affected: Individual Prospect Apps (Prospect CRM App, Prospect CMS Editor App, Hosted Customer Websites, Portals and eCommerce sites) and Our Website, APIs, Login, and Core Platform.