Degraded performance of Prospect CRM
Incident Report for Prospect CRM's
Resolved
This incident has been resolved by Azure.
Posted Sep 04, 2020 - 10:43 BST
Identified
This is related to an issue with Azure Virtual Machines in West Europe. Tracking ID is https://app.azure.com/h/8KLC-1T8/642ead. For those without access to Azure, here is the summary from Microsoft :

Starting at approximately 09:30 UTC on 03 Sep 2020 a subset of customers using Virtual Machines in West Europe may experience latency when accessing some resources. Engineers are evaluating mitigation options and are determining the best course of action. The next update will be provided in 60 mins, or as events warrant.
Posted Sep 03, 2020 - 18:29 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2020 - 12:20 BST
Investigating
Some customers have reported slower than expected performance of Prospect CRM and associated services. We are currently investigating and will provide further updates as information becomes available.
Posted Sep 03, 2020 - 11:05 BST
This incident affected: Individual Prospect Apps (Prospect CRM App).