Microsoft Azure AD B2C Outage
Incident Report for Prospect CRM's
Resolved
This incident has now been resolved and login services continue to perform as expected.

Microsoft have published a preliminary root cause for the outage, which can be accessed here (Tracking ID TTCR-NTZ):
https://status.azure.com/en-us/status/history/
Posted Mar 16, 2022 - 12:47 GMT
Monitoring
Microsoft have now mitigated the issue with Azure AD B2C and our login services have been restored. Microsoft have provided the following update:

"Between 09:13 and 10:09 UTC on 16 Mar 2022, a subset of end users of customers using Azure Active Directory B2C may have experienced failures and error notifications when attempting to authenticate. Retry attempts were likely to succeed during this incident. This issue is now mitigated."

We will continue to monitor the situation and provide any relevant updates.
Posted Mar 16, 2022 - 10:57 GMT
Investigating
Microsoft is currently experiencing an issue with Azure AD B2C, which is responsible for user login across the Prospect platform.
We are monitoring the situation and will provide updates when we have them.
Posted Mar 16, 2022 - 09:46 GMT
This incident affected: Our Website and APIs, Login, and Core Platform.