Degraded performance of Prospect CRM

Incident Report for Prospect CRM's

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 11:47 GMT

Update

We are continuing to monitor for any further issues.
Posted Dec 08, 2025 - 13:37 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 08, 2025 - 13:37 GMT

Identified

We have identified further issues which customers have reported while logging into the CRM. We are currently applying additional fixes.
Posted Dec 08, 2025 - 04:03 GMT

Monitoring

We have identified the issue and have applied a fix which should resolve the loading issue. We can confirmed CRM is working correctly and customers are recommended to clear their browser cache. You can read about clearing your browser cache here: https://docs.prospect365.com/en/articles/4304884-resolving-browser-related-issues-clearing-browser-caches
We will continue to monitor this issue.
Posted Dec 08, 2025 - 01:20 GMT

Investigating

Some customers have reported issues logging into the CRM. We are currently investigating and will provide further updates as information becomes available
Posted Dec 07, 2025 - 22:57 GMT
This incident affected: Individual Prospect Apps (Prospect CRM App).