Unable to log into the CRM
Incident Report for Prospect CRM's
Resolved
This incident has been resolved.
Posted Jan 06, 2025 - 10:02 GMT
Update
We are continuing to monitor for any further issues.
Posted Jan 06, 2025 - 08:18 GMT
Monitoring
A fix has been carried out and users should be able to log into the CRM normally. We will continue to monitor this issue.
Posted Jan 06, 2025 - 08:18 GMT
Update
For customers affected by this, CRM should be accessible via this URL as a workaround while the main cause is being investigated: https://preview.crm.prospect365.com
Posted Jan 06, 2025 - 07:30 GMT
Investigating
We are currently investigating an issue where some customers have reported that they cannot log into the CRM
Posted Jan 06, 2025 - 07:24 GMT
This incident affected: Individual Prospect Apps (Prospect CRM App).