Degraded performance of Prospect CRM

Incident Report for Prospect CRM's

Resolved

This incident has been resolved.
Posted Nov 04, 2019 - 15:45 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2019 - 13:13 GMT

Identified

Some customers have reported slower than expected performance of Prospect CRM and associated services. We are currently investigating and will provide further updates as information becomes available.
Posted Nov 04, 2019 - 12:38 GMT
This incident affected: Individual Prospect Apps (Prospect CRM App) and APIs, Login, and Core Platform.