Degraded performance of Prospect CRM

Incident Report for Prospect CRM's

Resolved

This incident has been resolved.
Posted 3 days ago. Mar 31, 2025 - 12:24 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 4 days ago. Mar 31, 2025 - 09:09 BST

Identified

The issue has been identified and a fix is being implemented.
Posted 4 days ago. Mar 31, 2025 - 09:05 BST

Investigating

Some customers have reported slower than expected performance of Prospect CRM and associated services. We are currently investigating and will provide further updates as information becomes available.
Posted 4 days ago. Mar 31, 2025 - 09:03 BST
This incident affected: Individual Prospect Apps (Prospect CRM App, Prospect CMS Editor App) and APIs, Login, and Core Platform.